summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/knocker/knocker-0.7.1-r2.ebuild')
-rw-r--r--net-analyzer/knocker/knocker-0.7.1-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/knocker/knocker-0.7.1-r2.ebuild b/net-analyzer/knocker/knocker-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..de9a3307edad
--- /dev/null
+++ b/net-analyzer/knocker/knocker-0.7.1-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base toolchain-funcs
+
+DESCRIPTION="Knocker is an easy to use security port scanner written in C"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://knocker.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TO-DO"
+
+PATCHES=( "${FILESDIR}"/${P}-free.patch )
+
+src_prepare() {
+ # fix configure checks for compiler, wrt bug #442962
+ tc-export CC
+
+ base_src_prepare
+}