summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/knocker/knocker-0.7.1-r3.ebuild')
-rw-r--r--net-analyzer/knocker/knocker-0.7.1-r3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-analyzer/knocker/knocker-0.7.1-r3.ebuild b/net-analyzer/knocker/knocker-0.7.1-r3.ebuild
new file mode 100644
index 000000000000..55ca0de66051
--- /dev/null
+++ b/net-analyzer/knocker/knocker-0.7.1-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base toolchain-funcs
+
+DESCRIPTION="Knocker is an easy to use security port scanner written in C"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://knocker.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README TO-DO )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fency.patch \
+ "${FILESDIR}"/${P}-free.patch \
+ "${FILESDIR}"/${P}-knocker_user_is_root.patch
+
+ tc-export CC
+}