summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch')
-rw-r--r--net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch b/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch
new file mode 100644
index 000000000000..c82f76d60016
--- /dev/null
+++ b/net-analyzer/libnasl/files/libnasl-2.2.9-gentoo.patch
@@ -0,0 +1,29 @@
+index 860653d..82bdf2f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ include nasl.tmpl
+
+ all:
+- cd nasl && ${MAKE}
++ ${MAKE} -C nasl
+
+ nasl.tmpl: nasl.tmpl.in configure
+ $(SHELL) configure $(CONFIGURE_ARGS)
+--- a/nasl/Makefile
++++ b/nasl/Makefile
+@@ -97,11 +97,11 @@ cflags :
+ @echo "echo \"$(NESSUS_CFLAGS) $(include) $(DEFS) \"" > cflags
+ @chmod +x cflags
+
+-nasl : cflags $(OBJS) nasl.c
+- $(CC) $(CFLAGS) $(NESSUS_INCLUDE) $(include) -o nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
++nasl : cflags $(OBJS) nasl.c libnasl.la
++ $(CC) $(CFLAGS) $(LDFLAGS) $(NESSUS_INCLUDE) $(include) -o nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
+
+ libnasl.la : cflags $(OBJS)
+- $(COMPILE) $(NESSUS_LIBS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
++ $(COMPILE) $(NESSUS_LIBS) $(LDFLAGS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
+ -version-info ${PACKAGE_VERSION}
+
+ install : libnasl.la nasl