summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios-plugins-snmp')
-rw-r--r--net-analyzer/nagios-plugins-snmp/Manifest1
-rw-r--r--net-analyzer/nagios-plugins-snmp/metadata.xml17
-rw-r--r--net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild46
3 files changed, 64 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins-snmp/Manifest b/net-analyzer/nagios-plugins-snmp/Manifest
new file mode 100644
index 000000000000..af435cde4b89
--- /dev/null
+++ b/net-analyzer/nagios-plugins-snmp/Manifest
@@ -0,0 +1 @@
+DIST nagios-plugins-snmp-0.6.0.tgz 381664 SHA256 c3616feeb817165bc356df8f2daef52e1077f5d97a35c8074cadc68e15c0fff5 SHA512 42fe9e2a9a99876d81731d821b7d1e4700f8637c8a890980f5cb3de4a3985210d86d38fd7ebbd7d075ff616da518cc932f5eb999f47fc3833ed62c1f7d4f4529 WHIRLPOOL 74fd6272690e307bfa996d6db08230dfc4314f14a2e146545913b4d0b42a42168560dded9be51c101a7571411663d74d78a9d1a35d9119b67c3765f28d33187f
diff --git a/net-analyzer/nagios-plugins-snmp/metadata.xml b/net-analyzer/nagios-plugins-snmp/metadata.xml
new file mode 100644
index 000000000000..fad986e477b0
--- /dev/null
+++ b/net-analyzer/nagios-plugins-snmp/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>andrew@ahamilto.net</email>
+ <name>Andrew Hamilton</name>
+ <description>Maintainer. Assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>creffett@gentoo.org</email>
+ <name>Chris Reffett</name>
+ <description>Proxy maintainer. CC him on bugs.</description>
+ </maintainer>
+ <herd>proxy-maintainers</herd>
+ <herd>sysadmin</herd>
+</pkgmetadata>
+
diff --git a/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild b/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..aa6272077bda
--- /dev/null
+++ b/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools user
+
+DESCRIPTION="Additional Nagios plugins for monitoring SNMP capable devices"
+HOMEPAGE="http://nagios.manubulon.com"
+SRC_URI="http://nagios.manubulon.com/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 ~sparc x86"
+IUSE=""
+
+DEPEND="net-analyzer/net-snmp"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/nagios-plugins-snmp
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_prepare() {
+ sed -i -e '/^CFLAGS=""/d' configure.in
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/nagios \
+ --libexec=/usr/$(get_libdir)/nagios/plugins
+}
+
+DOCS=( README NEWS AUTHORS )
+
+src_install() {
+ default
+
+ fowners root:nagios /usr/$(get_libdir)/nagios/plugins
+ fperms o-rwx /usr/$(get_libdir)/nagios/plugins
+}