summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ndsad/ndsad-1.33-r1.ebuild')
-rw-r--r--net-analyzer/ndsad/ndsad-1.33-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/ndsad/ndsad-1.33-r1.ebuild b/net-analyzer/ndsad/ndsad-1.33-r1.ebuild
new file mode 100644
index 000000000000..3b8e21aeb43c
--- /dev/null
+++ b/net-analyzer/ndsad/ndsad-1.33-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Cisco netflow probe from libpcap, ULOG, tee/divert sources"
+HOMEPAGE="http://sourceforge.net/projects/ndsad"
+SRC_URI="mirror://sourceforge/ndsad/ndsad-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=net-libs/libpcap-0.8"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-conf_path.patch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-getpid.patch \
+ "${FILESDIR}"/${P}-log-path.patch \
+ "${FILESDIR}"/${P}-strncpy-overflow.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-ulog=yes
+}
+
+DOCS=( ChangeLog AUTHORS README )
+
+src_install() {
+ default
+
+ doman ndsad.conf.5
+
+ insinto /etc
+ newins ndsad.conf ndsad.conf
+
+ newinitd "${FILESDIR}"/ndsad.init ndsad
+ newconfd "${FILESDIR}"/ndsad.conf.d ndsad
+}