summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nessus-plugins/files/2.2.9-gentoo.patch')
-rw-r--r--net-analyzer/nessus-plugins/files/2.2.9-gentoo.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/nessus-plugins/files/2.2.9-gentoo.patch b/net-analyzer/nessus-plugins/files/2.2.9-gentoo.patch
new file mode 100644
index 000000000000..39366844382f
--- /dev/null
+++ b/net-analyzer/nessus-plugins/files/2.2.9-gentoo.patch
@@ -0,0 +1,58 @@
+ plugins/find_service/Makefile | 2 +-
+ plugins/nessus_tcp_scanner/Makefile | 2 +-
+ plugins/ssl_ciphers/Makefile | 2 +-
+ plugins/synscan/Makefile | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/plugins/find_service/Makefile b/plugins/find_service/Makefile
+index f4fd8e3..12e62a3 100644
+--- a/plugins/find_service/Makefile
++++ b/plugins/find_service/Makefile
+@@ -5,7 +5,7 @@ PLUGNAME=find_service
+ all : $(PLUGNAME).nes
+ $(PLUGNAME).nes : $(PLUGNAME).c
+ $(LIBTOOL) $(CC) $(DEFS) $(include) -c $(PLUGNAME).c
+- $(LIBTOOL) $(CC) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
++ $(LIBTOOL) $(CC) $(LDFLAGS) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
+ -rpath $(rootdir)/bin/plugins
+ ../install_plug $(PLUGNAME) $(rootdir)
+ clean :
+diff --git a/plugins/nessus_tcp_scanner/Makefile b/plugins/nessus_tcp_scanner/Makefile
+index 8cf6c6d..7a27495 100644
+--- a/plugins/nessus_tcp_scanner/Makefile
++++ b/plugins/nessus_tcp_scanner/Makefile
+@@ -8,7 +8,7 @@ PLUGNAME=nessus_tcp_scanner
+ all : $(PLUGNAME).nes
+ $(PLUGNAME).nes : $(PLUGNAME).c
+ $(LIBTOOL) $(CC) $(DEFS) $(include) -c $(PLUGNAME).c
+- $(LIBTOOL) $(CC) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) -lm $(LIBUTIL) \
++ $(LIBTOOL) $(CC) $(LDFLAGS) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) -lm $(LIBUTIL) \
+ -rpath $(rootdir)/bin/plugins
+ ../install_plug $(PLUGNAME) $(rootdir)
+ clean :
+diff --git a/plugins/ssl_ciphers/Makefile b/plugins/ssl_ciphers/Makefile
+index dc10e64..1747745 100644
+--- a/plugins/ssl_ciphers/Makefile
++++ b/plugins/ssl_ciphers/Makefile
+@@ -5,7 +5,7 @@ PLUGNAME=ssl_ciphers
+ all : $(PLUGNAME).nes
+ $(PLUGNAME).nes : $(PLUGNAME).c
+ $(LIBTOOL) $(CC) $(DEFS) $(include) -c $(PLUGNAME).c
+- $(LIBTOOL) $(CC) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
++ $(LIBTOOL) $(CC) $(LDFLAGS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
+ -rpath $(rootdir)/bin/plugins
+ ../install_plug $(PLUGNAME) $(rootdir)
+ clean :
+diff --git a/plugins/synscan/Makefile b/plugins/synscan/Makefile
+index 16aefa1..c434b92 100644
+--- a/plugins/synscan/Makefile
++++ b/plugins/synscan/Makefile
+@@ -5,7 +5,7 @@ PLUGNAME=synscan
+ all : $(PLUGNAME).nes
+ $(PLUGNAME).nes : $(PLUGNAME).c
+ $(LIBTOOL) $(CC) $(DEFS) $(include) -c $(PLUGNAME).c
+- $(LIBTOOL) $(CC) $(DEFS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
++ $(LIBTOOL) $(CC) $(DEFS) $(LDFLAGS) -o lib$(PLUGNAME).la $(PLUGNAME).lo $(LIBS) \
+ -rpath $(rootdir)/bin/plugins
+ ../install_plug $(PLUGNAME) $(rootdir)
+ clean :