summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nload/nload-0.7.4-r1.ebuild')
-rw-r--r--net-analyzer/nload/nload-0.7.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/nload/nload-0.7.4-r1.ebuild b/net-analyzer/nload/nload-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..d65af8f42024
--- /dev/null
+++ b/net-analyzer/nload/nload-0.7.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Real time network traffic monitor for the command line interface"
+HOMEPAGE="http://www.roland-riegel.de/nload/index.html"
+SRC_URI="http://www.roland-riegel.de/nload/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+
+RDEPEND=">=sys-libs/ncurses-5.2:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # --enable-debug means do not strip debugging symbols (default no)
+ econf --enable-debug
+}