summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ntopng/ntopng-1.2.1.ebuild')
-rw-r--r--net-analyzer/ntopng/ntopng-1.2.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/ntopng-1.2.1.ebuild b/net-analyzer/ntopng/ntopng-1.2.1.ebuild
new file mode 100644
index 000000000000..b5725cab8570
--- /dev/null
+++ b/net-analyzer/ntopng/ntopng-1.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools user
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="http://www.ntop.org/"
+SRC_URI="mirror://sourceforge/ntop/${PN}/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-db/sqlite:3
+ dev-libs/geoip
+ dev-libs/glib:2
+ net-libs/libpcap"
+RDEPEND="${DEPEND}
+ dev-db/redis"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ SHARE_NTOPNG_DIR="${EPREFIX}/usr/share/${PN}"
+ dodir ${SHARE_NTOPNG_DIR}
+ insinto ${SHARE_NTOPNG_DIR}
+ doins -r httpdocs
+ doins -r scripts
+
+ exeinto /usr/bin
+ doexe ${PN}
+ doman ${PN}.8
+
+ newinitd "${FILESDIR}/ntopng.init.d" ntopng
+ newconfd "${FILESDIR}/ntopng.conf.d" ntopng
+
+ dodir "/var/lib/ntopng"
+ fowners ntopng "${EPREFIX}/var/lib/ntopng"
+}
+
+pkg_setup() {
+ enewuser ntopng
+}
+
+pkg_postinst() {
+ elog "ntopng default creadential are user='admin' password='admin'"
+}