summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/oinkmaster/oinkmaster-2.0.ebuild')
-rw-r--r--net-analyzer/oinkmaster/oinkmaster-2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/oinkmaster/oinkmaster-2.0.ebuild b/net-analyzer/oinkmaster/oinkmaster-2.0.ebuild
new file mode 100644
index 000000000000..49b8ef0ec8b4
--- /dev/null
+++ b/net-analyzer/oinkmaster/oinkmaster-2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Rule management for SNORT"
+SRC_URI="mirror://sourceforge/oinkmaster/${P}.tar.gz"
+HOMEPAGE="http://oinkmaster.sf.net/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc sparc x86"
+IUSE="X"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.1
+ X? ( dev-perl/perl-tk )
+ net-misc/wget
+ app-arch/tar
+ app-arch/gzip
+"
+
+src_install() {
+ dobin \
+ contrib/addmsg.pl \
+ contrib/addsid.pl \
+ contrib/create-sidmap.pl \
+ contrib/makesidex.pl \
+ oinkmaster.pl
+
+ use X && dobin contrib/oinkgui.pl
+
+ dodoc FAQ README README.gui README.win32 UPGRADING contrib/README.contrib
+
+ doman oinkmaster.1
+
+ insinto /etc
+ doins oinkmaster.conf
+}