summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ospd/ospd-1.0.0.ebuild')
-rw-r--r--net-analyzer/ospd/ospd-1.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/ospd/ospd-1.0.0.ebuild b/net-analyzer/ospd/ospd-1.0.0.ebuild
new file mode 100644
index 000000000000..a22ef50f4e1b
--- /dev/null
+++ b/net-analyzer/ospd/ospd-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DL_ID=1999
+
+DESCRIPTION="Collection of scanner wrappers for OpenVAS"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P/_beta/+beta}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${P/_beta/-beta}
+
+_DOCS=( ChangeLog CHANGES README )
+
+python_test() {
+ esetup.py test
+}