summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/siphon/files/siphon-666-gentoo.patch')
-rw-r--r--net-analyzer/siphon/files/siphon-666-gentoo.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/net-analyzer/siphon/files/siphon-666-gentoo.patch b/net-analyzer/siphon/files/siphon-666-gentoo.patch
new file mode 100644
index 000000000000..eea6d93b802e
--- /dev/null
+++ b/net-analyzer/siphon/files/siphon-666-gentoo.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ CC = gcc
+ CCFLAGS = -Wall -pthread -ggdb
+-CFLAGS = -Wall -O2 -pthread -ggdb -I.
++CFLAGS += -pthread -Wall -I.
+ LIBS = -lpcap
+ OBJS = parse.o sniff.o main.o log.o
+ SRCS = ${OBJS:.o=.c}
+@@ -9,7 +9,7 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CCFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
++ $(CC) $(CCFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+ clean:
+ rm -f $(OBJS) *~ *.core core siphon