summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/softflowd/softflowd-0.9.9-r1.ebuild')
-rw-r--r--net-analyzer/softflowd/softflowd-0.9.9-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/softflowd/softflowd-0.9.9-r1.ebuild b/net-analyzer/softflowd/softflowd-0.9.9-r1.ebuild
new file mode 100644
index 000000000000..06446a44b830
--- /dev/null
+++ b/net-analyzer/softflowd/softflowd-0.9.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="flow-based network traffic analyser capable of Cisco NetFlow data export"
+HOMEPAGE="http://www.mindrot.org/projects/softflowd/"
+SRC_URI="http://softflowd.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-strip.patch
+ epatch "${FILESDIR}"/${P}-_GNU_SOURCE.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc collector.pl
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}