summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcping/tcping-1.3.5.ebuild')
-rw-r--r--net-analyzer/tcping/tcping-1.3.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/tcping/tcping-1.3.5.ebuild b/net-analyzer/tcping/tcping-1.3.5.ebuild
new file mode 100644
index 000000000000..757cf94048a1
--- /dev/null
+++ b/net-analyzer/tcping/tcping-1.3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Ping implementation that uses the TCP protocol"
+HOMEPAGE="http://www.linuxco.de/tcping/tcping.html"
+SRC_URI="http://www.linuxco.de/tcping/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -e '/^CC=/s:=:?=:' \
+ -e '/^CCFLAGS/s:=:+=:' \
+ -e 's/$(CCFLAGS)/$(CCFLAGS) $(LDFLAGS)/' \
+ -i Makefile || die
+ tc-export CC
+ export CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcping
+ dodoc README
+}