summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild')
-rw-r--r--net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild b/net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild
new file mode 100644
index 000000000000..bd92dc5b2477
--- /dev/null
+++ b/net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="Reports network interface statistics"
+SRC_URI="http://www.frenchfries.net/paul/tcpstat/${P}.tar.gz"
+HOMEPAGE="http://www.frenchfries.net/paul/tcpstat/"
+
+DEPEND="net-libs/libpcap"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="amd64 ~ppc ~ppc64 sparc x86"
+
+IUSE="ipv6"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-db.patch"
+ eautoreconf
+}
+
+src_compile() {
+ append-flags -Wall -Wextra
+ econf $(use_enable ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "emake install failed"
+ dobin src/{catpcap,packetdump} || die "dobin failed"
+ dodoc AUTHORS ChangeLog NEWS README doc/Tips_and_Tricks.txt
+ newdoc src/README README.src
+}