summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/thc-ipv6/thc-ipv6-2.3.ebuild')
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-2.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-2.3.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-2.3.ebuild
new file mode 100644
index 000000000000..cce92b30e763
--- /dev/null
+++ b/net-analyzer/thc-ipv6/thc-ipv6-2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
+HOMEPAGE="http://freeworld.thc.org/thc-ipv6/"
+SRC_URI="http://freeworld.thc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-3 openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND="net-libs/libpcap
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1-Makefile.patch
+ if ! use ssl ; then
+ sed -e '/^HAVE_SSL/s:^:#:' \
+ -i Makefile
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" STRIP="true" install
+ dodoc CHANGES HOWTO-INJECT README
+}