summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/thrulay/thrulay-0.9-r1.ebuild')
-rw-r--r--net-analyzer/thrulay/thrulay-0.9-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/thrulay/thrulay-0.9-r1.ebuild b/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
new file mode 100644
index 000000000000..59059fea408a
--- /dev/null
+++ b/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs autotools
+
+DESCRIPTION="Measure the capacity of a network by sending a bulk TCP stream over it"
+HOMEPAGE="http://www.internet2.edu/~shalunov/thrulay/"
+SRC_URI="http://www.internet2.edu/~shalunov/thrulay/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+DEPEND=""
+
+src_prepare() {
+ echo 'thrulay thrulayd: libthrulay.la' >>src/Makefile.am
+ eautoreconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ #dobin src/thrulay || die "dobin failed"
+ #dosbin src/thrulayd || die "dosbin failed"
+ dodoc LICENSE README TODO doc/thrulay-protocol.txt || die "dodoc failed"
+ doman doc/thrulay*.[1-8] || die "doman failed"
+ newinitd "${FILESDIR}"/thrulayd-init.d thrulayd || die "newinitd failed"
+ newconfd "${FILESDIR}"/thrulayd-conf.d thrulayd || die "newconfd failed"
+}