summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/traceroute/traceroute-2.0.18.ebuild')
-rw-r--r--net-analyzer/traceroute/traceroute-2.0.18.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/traceroute/traceroute-2.0.18.ebuild b/net-analyzer/traceroute/traceroute-2.0.18.ebuild
new file mode 100644
index 000000000000..1d1619984755
--- /dev/null
+++ b/net-analyzer/traceroute/traceroute-2.0.18.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Utility to trace the route of IP packets"
+HOMEPAGE="http://traceroute.sourceforge.net/"
+SRC_URI="mirror://sourceforge/traceroute/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE="static"
+
+src_compile() {
+ use static && append-ldflags -static
+ tc-export CC AR RANLIB
+ emake env=yes || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" \
+ install \
+ || die
+ dodoc ChangeLog CREDITS README TODO
+}