summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ttcp/ttcp-1.12-r2.ebuild')
-rw-r--r--net-analyzer/ttcp/ttcp-1.12-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/ttcp/ttcp-1.12-r2.ebuild b/net-analyzer/ttcp/ttcp-1.12-r2.ebuild
new file mode 100644
index 000000000000..1f8cb4251e5e
--- /dev/null
+++ b/net-analyzer/ttcp/ttcp-1.12-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to test TCP and UDP throughput"
+HOMEPAGE="
+ http://ftp.arl.mil/~mike/ttcp.html
+ http://www.netcore.fi/pekkas/linux/ipv6/
+"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
+ http://www.netcore.fi/pekkas/linux/ipv6/${PN}.c
+"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} "${DISTDIR}"/${PN}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+ newman sgi-${PN}.1 ${PN}.1
+}