summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/files/wireshark-1.99.0.1975-sse4_2.patch')
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.99.0.1975-sse4_2.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-1.99.0.1975-sse4_2.patch b/net-analyzer/wireshark/files/wireshark-1.99.0.1975-sse4_2.patch
new file mode 100644
index 000000000000..ba61de645354
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.99.0.1975-sse4_2.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -985,6 +985,7 @@
+ AC_SUBST(PIE_CFLAGS)
+ AC_SUBST(PIE_LDFLAGS)
+
++AC_ARG_ENABLE(sse4_2,[ --enable-sse4_2 Support SSE4.2 (Streaming SIMD Extensions 4.2) instructions],[
+ CFLAGS_before_simd="$CFLAGS"
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-msse4.2, C)
+ if test "x$CFLAGS" != "x$CFLAGS_before_simd"
+@@ -1011,6 +1012,9 @@
+ else
+ have_sse42=no
+ fi
++],[
++AC_MSG_RESULT(no)
++])
+ dnl build libwsutil_sse42 only if there is SSE4.2
+ AM_CONDITIONAL(SSE42_SUPPORTED, test "x$have_sse42" = "xyes")
+ AC_SUBST(CFLAGS_SSE42)