summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/xnetload/xnetload-1.11.3-r1.ebuild')
-rw-r--r--net-analyzer/xnetload/xnetload-1.11.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/xnetload/xnetload-1.11.3-r1.ebuild b/net-analyzer/xnetload/xnetload-1.11.3-r1.ebuild
new file mode 100644
index 000000000000..6b3ef4dcc97e
--- /dev/null
+++ b/net-analyzer/xnetload/xnetload-1.11.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="displays a count and a graph of the traffic over a specified network connection"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.xs4all.nl/~rsmith/software/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:CFLAGS = -pipe -O2 -Wall:CFLAGS += -Wall:' \
+ -e 's:LFLAGS = -s -pipe:LFLAGS = $(LDFLAGS):' \
+ -e 's:gcc -MM:$(CC) -MM:' \
+ -e 's:/usr/X11R6:/usr:g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin xnetload
+ doman xnetload.1
+ dodoc ChangeLog README
+ insinto /usr/share/X11/app-defaults/
+ doins XNetload
+}