summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/zmap/zmap-1.2.1.ebuild')
-rw-r--r--net-analyzer/zmap/zmap-1.2.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/zmap/zmap-1.2.1.ebuild b/net-analyzer/zmap/zmap-1.2.1.ebuild
new file mode 100644
index 000000000000..ad8d5042776f
--- /dev/null
+++ b/net-analyzer/zmap/zmap-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils fcaps
+
+DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
+HOMEPAGE="https://zmap.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="json redis"
+
+RDEPEND="
+ dev-libs/gmp
+ net-libs/libpcap
+ json? ( dev-libs/json-c )
+ redis? ( dev-libs/hiredis )"
+DEPEND="${RDEPEND}
+ dev-util/gengetopt
+ sys-devel/flex
+ dev-util/byacc"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEVELOPMENT=OFF
+ -DENABLE_HARDENING=OFF
+ -DWITH_WERROR=OFF
+ $(cmake-utils_use_with json)
+ $(cmake-utils_use_with redis)
+ )
+ cmake-utils_src_configure
+}
+
+FILECAPS=( cap_net_raw=ep usr/sbin/zmap )