summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/zmap/zmap-9999.ebuild')
-rw-r--r--net-analyzer/zmap/zmap-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/zmap/zmap-9999.ebuild b/net-analyzer/zmap/zmap-9999.ebuild
new file mode 100644
index 000000000000..d4ba7486a0f1
--- /dev/null
+++ b/net-analyzer/zmap/zmap-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils fcaps git-r3
+
+DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
+HOMEPAGE="https://zmap.io/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/zmap/zmap.git"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS=""
+IUSE="json redis"
+
+RDEPEND="
+ dev-libs/gmp
+ net-libs/libpcap
+ json? ( dev-libs/json-c )
+ redis? ( dev-libs/hiredis )"
+DEPEND="${RDEPEND}
+ dev-util/gengetopt
+ sys-devel/flex
+ dev-util/byacc
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEVELOPMENT=OFF
+ -DENABLE_HARDENING=OFF
+ -DWITH_WERROR=OFF
+ $(cmake-utils_use_with json)
+ $(cmake-utils_use_with redis)
+ )
+ cmake-utils_src_configure
+}
+
+FILECAPS=( cap_net_raw=ep usr/sbin/zmap )