summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/zniper/zniper-1.0-r1.ebuild')
-rw-r--r--net-analyzer/zniper/zniper-1.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/zniper/zniper-1.0-r1.ebuild b/net-analyzer/zniper/zniper-1.0-r1.ebuild
new file mode 100644
index 000000000000..5a996e5925f8
--- /dev/null
+++ b/net-analyzer/zniper/zniper-1.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Displays and kill active TCP connections seen by the selected interface"
+HOMEPAGE="http://www.signedness.org/tools/"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/"zniper"
+
+src_prepare() {
+ sed -i \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ -e 's|@make|@$(MAKE)|g' \
+ -e 's|-lncurses|$(shell $(PKG_CONFIG) --libs ncurses)|g' \
+ Makefile || die
+ tc-export PKG_CONFIG
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ linux_x86
+}
+
+src_install() {
+ dobin zniper
+ doman zniper.1
+}