summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild')
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
index 7bc0187ab8ce..4f7ddaa4a1b8 100644
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
@@ -39,6 +39,11 @@ src_compile() {
popd >/dev/null || die
}
+src_test() {
+ cd "${PN}" || die
+ go test -mod=vendor -buildmode="$(usex pie pie default)" || die "Failed to run tests"
+}
+
src_install() {
pushd "${PN}" >/dev/null || die