summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/pdns-ldap-backend/pdns-ldap-backend-0.2.ebuild')
-rw-r--r--net-dns/pdns-ldap-backend/pdns-ldap-backend-0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-dns/pdns-ldap-backend/pdns-ldap-backend-0.2.ebuild b/net-dns/pdns-ldap-backend/pdns-ldap-backend-0.2.ebuild
new file mode 100644
index 000000000000..01fa5dbf8b7b
--- /dev/null
+++ b/net-dns/pdns-ldap-backend/pdns-ldap-backend-0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Fork of the official but unmaintained LDAP backend"
+HOMEPAGE="http://repo.or.cz/w/pdns-ldap-backend.git http://sequanux.org/cgi-bin/mailman/listinfo/pdns-ldap-backend"
+SRC_URI="http://sequanux.org/dl/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="sasl"
+
+DEPEND=">=net-dns/pdns-3.2[-ldap]
+ net-nds/openldap[sasl=]
+ virtual/krb5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-pdns="${EPREFIX}/usr/include" \
+ --libdir=/usr/$(get_libdir)/powerdns
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README USAGE* src/dns.ldif"
+ default
+ prune_libtool_files --all
+ insinto /etc/openldap/schema
+ doins schema/*
+}