summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/tinystats/tinystats-1.1.ebuild')
-rw-r--r--net-dns/tinystats/tinystats-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-dns/tinystats/tinystats-1.1.ebuild b/net-dns/tinystats/tinystats-1.1.ebuild
new file mode 100644
index 000000000000..1b6ac24658ec
--- /dev/null
+++ b/net-dns/tinystats/tinystats-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tinydns logging helper app"
+HOMEPAGE="http://www.morettoni.net/tinystats.en.html"
+SRC_URI="http://www.morettoni.net/bsd/${P}.tar.gz"
+IUSE="ipv6"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+RDEPEND="net-dns/djbdns"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ use ipv6 && IPV6="-D WITH_IPV6"
+ $(tc-getCC) ${CFLAGS} ${IPV6} -o tinystats ${LDFLAGS} tinystats.c || \
+ die "compile failed"
+}
+
+src_install() {
+ dobin tinystats || die 'dobin failed'
+ dodoc README
+ docinto sample
+ dodoc start_slave.sh.sample update_slave.sh.sample \
+ tinydns.log.run.sample tinydns.sh.sample
+}