summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/nsd/nsd-4.1.25.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-dns/nsd/nsd-4.1.25.ebuild b/net-dns/nsd/nsd-4.1.25.ebuild
index 9a5fc16aa9bb..c5b30a4d01a1 100644
--- a/net-dns/nsd/nsd-4.1.25.ebuild
+++ b/net-dns/nsd/nsd-4.1.25.ebuild
@@ -93,7 +93,7 @@ src_install() {
# remove the /run directory that usually resides on tmpfs and is
# being taken care of by the nsd init script anyway (checkpath)
- rm -r "${ED%/}"/run || die "Failed to remove /run"
+ rm -r "${ED}"/run || die "Failed to remove /run"
keepdir /var/db/${PN}
}
@@ -104,8 +104,8 @@ pkg_postinst() {
enewuser nsd -1 -1 -1 nsd
# database directory, writable by nsd for database updates and zone transfers
- install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/db/nsd
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/db/nsd
# zones directory, writable by nsd for zone file updates (nsd-control write)
- install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/lib/nsd
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/lib/nsd
}