summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/ipt_netflow/files')
-rw-r--r--net-firewall/ipt_netflow/files/ipt_netflow-2.5-gentoo.patch61
-rw-r--r--net-firewall/ipt_netflow/files/ipt_netflow-2.5.1-vlan_dev_priv.patch32
2 files changed, 0 insertions, 93 deletions
diff --git a/net-firewall/ipt_netflow/files/ipt_netflow-2.5-gentoo.patch b/net-firewall/ipt_netflow/files/ipt_netflow-2.5-gentoo.patch
deleted file mode 100644
index 508be107795e..000000000000
--- a/net-firewall/ipt_netflow/files/ipt_netflow-2.5-gentoo.patch
+++ /dev/null
@@ -1,61 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -11,7 +11,7 @@
- SNMPTGSO = /usr/lib/snmp/dlmod/snmp_NETFLOW.so
- SNMPCONF = /etc/snmp/snmpd.conf
- SNMPLINE = dlmod netflow $(SNMPTGSO)
--CC = gcc
-+CC ?= gcc
-
- # https://www.kernel.org/doc/Documentation/kbuild/modules.txt
- # https://www.kernel.org/doc/Documentation/kbuild/makefiles.txt
-@@ -22,31 +22,31 @@
-
- ipt_NETFLOW.ko: version.h ipt_NETFLOW.c ipt_NETFLOW.h compat_def.h compat.h Makefile
- @echo Compiling for kernel $(KVERSION)
-- make -C $(KDIR) M=$(CURDIR) modules CONFIG_DEBUG_INFO=y
-+ $(MAKE) -C $(KDIR) M=$(CURDIR) modules CONFIG_DEBUG_INFO=y
- @touch $@
- compat_def.h: gen_compat_def
- ./gen_compat_def > $@
- sparse: | version.h ipt_NETFLOW.c ipt_NETFLOW.h compat.h Makefile
- @rm -f ipt_NETFLOW.ko ipt_NETFLOW.o
- @echo Compiling for kernel $(KVERSION)
-- make -C $(KDIR) M=$(CURDIR) modules C=1
-+ $(MAKE) -C $(KDIR) M=$(CURDIR) modules C=1
- @touch ipt_NETFLOW.ko
- coverity:
- coverity-submit -v
-
- minstall: | ipt_NETFLOW.ko
- @echo " *"
-- make -C $(KDIR) M=$(CURDIR) modules_install INSTALL_MOD_PATH=$(DESTDIR)
-+ $(MAKE) -C $(KDIR) M=$(CURDIR) modules_install INSTALL_MOD_PATH=$(DESTDIR)
- $(DEPMOD)
- mclean:
-- make -C $(KDIR) M=$(CURDIR) clean
-+ $(MAKE) -C $(KDIR) M=$(CURDIR) clean
- lclean:
- -rm -f *.so *_sh.o
- clean: mclean lclean
- -rm -f *.so *.o modules.order version.h compat_def.h
-
- snmp_NETFLOW.so: snmp_NETFLOW.c
-- $(CC) -fPIC -shared -o $@ $< -lnetsnmp
-+ $(CC) $(CFLAGS) $(LDFLAGS) -fPIC -shared -o $@ $< -lnetsnmp
-
- sinstall: | snmp_NETFLOW.so IPT-NETFLOW-MIB.my
- @echo " *"
-@@ -66,10 +66,10 @@
- fi
-
- %_sh.o: libipt_NETFLOW.c
-- $(CC) $(CFLAGS) -O2 -Wall -Wunused $(IPTABLES_CFLAGS) -fPIC -o $@ -c libipt_NETFLOW.c
-+ $(CC) $(CFLAGS) -Wall -Wunused $(IPTABLES_CFLAGS) -fPIC -o $@ -c libipt_NETFLOW.c
-
- %.so: %_sh.o
-- $(CC) -shared -o $@ $<
-+ $(CC) $(LDFLAGS) -shared -o $@ $<
-
- version.h: ipt_NETFLOW.c ipt_NETFLOW.h compat.h Makefile
- @./version.sh --define > version.h
diff --git a/net-firewall/ipt_netflow/files/ipt_netflow-2.5.1-vlan_dev_priv.patch b/net-firewall/ipt_netflow/files/ipt_netflow-2.5.1-vlan_dev_priv.patch
deleted file mode 100644
index 49721e547fd7..000000000000
--- a/net-firewall/ipt_netflow/files/ipt_netflow-2.5.1-vlan_dev_priv.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-commit 1153f73f038205dc17303e6e6c455bbbb56191f7
-Author: ABC <abc@openwall.com>
-Date: Wed Oct 14 15:35:57 2020 +0300
-
- gen_compat_def: Check for vlan_dev_priv instead of version if
-
-diff --git a/gen_compat_def b/gen_compat_def
-index c0f20f6..3965e94 100755
---- a/gen_compat_def
-+++ b/gen_compat_def
-@@ -85,6 +85,8 @@ kbuild_test_struct proc_ops linux/proc_fs.h
- kbuild_test_struct proc_ops linux/proc_fs.h
- # No since v5.1, but present in CentOS-8's 4.18.0-227
- kbuild_test_symbol synchronize_sched linux/rcupdate.h
-+# Stumbled on 5.9
-+kbuild_test_struct vlan_dev_priv linux/if_vlan.h
-
- echo "// End of compat_def.h"
-
-diff --git a/ipt_NETFLOW.c b/ipt_NETFLOW.c
-index 01055df..6f95166 100644
---- a/ipt_NETFLOW.c
-+++ b/ipt_NETFLOW.c
-@@ -4874,7 +4874,7 @@ static void parse_l2_header(const struct sk_buff *skb, struct ipt_netflow_tuple
- tuple->tag[tag_num++] = htons(vlan_tx_tag_get(skb));
- else if (skb->dev && is_vlan_dev(skb->dev)) {
- struct net_device *vlan_dev = skb->dev;
--# if LINUX_VERSION_CODE >= KERNEL_VERSION(3,2,0)
-+# ifdef HAVE_VLAN_DEV_PRIV
- struct vlan_dev_priv *vlan = vlan_dev_priv(vlan_dev);
-
- /* `if` condition is `#if`ed intentionally, and this is