summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/libnfs/libnfs-9999.ebuild')
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index 66c1685f1207..3c544aaa465a 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,44 +1,49 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
+
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
+ inherit git-r3
else
SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
- S="${WORKDIR}/${PN}-${P}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"
+ S="${WORKDIR}"/${PN}-${P}
fi
DESCRIPTION="Client library for accessing NFS shares over a network"
HOMEPAGE="https://github.com/sahlberg/libnfs"
LICENSE="LGPL-2.1 GPL-3"
-SLOT="0/13" # sub-slot matches SONAME major
+SLOT="0/14" # sub-slot matches SONAME major
IUSE="examples static-libs utils"
-RDEPEND=""
-DEPEND="${RDEPEND}
+# net-libs/rpcsvc-proto for rpcgen called in build system
+BDEPEND="net-libs/rpcsvc-proto
virtual/pkgconfig"
src_prepare() {
default
+
eautoreconf
}
src_configure() {
local myeconfargs=(
+ --disable-werror
$(use_enable static-libs static)
$(use_enable utils)
)
+
econf "${myeconfargs[@]}"
}
src_install() {
default
+
if use examples; then
# --enable-examples configure switch just compiles them
# better install sources instead
@@ -47,5 +52,6 @@ src_install() {
doexe examples/${program}.c
done
fi
+
find "${ED}" -name "*.la" -delete || die
}