summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/nfs-utils/files/nfs-utils-2.3.4-no-werror.patch')
-rw-r--r--net-fs/nfs-utils/files/nfs-utils-2.3.4-no-werror.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-fs/nfs-utils/files/nfs-utils-2.3.4-no-werror.patch b/net-fs/nfs-utils/files/nfs-utils-2.3.4-no-werror.patch
new file mode 100644
index 000000000000..7fc0dd1c7249
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-utils-2.3.4-no-werror.patch
@@ -0,0 +1,67 @@
+From 04c9e3cc26dd330d9cb524c02de610c3bccd4b7b Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 11 May 2019 22:51:35 +0200
+Subject: [PATCH] Don't build with -Werror flags
+
+https://bugs.gentoo.org/656984
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 34 +---------------------------------
+ 1 file changed, 1 insertion(+), 33 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4d70961..e6e709c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -574,46 +574,14 @@ AC_SUBST(CPPFLAGS_FOR_BUILD)
+ AC_SUBST(LDFLAGS_FOR_BUILD)
+
+ my_am_cflags="\
+- -pipe \
+ -Wall \
+ -Wextra \
+ $rpcgen_cflags \
+- -Werror=missing-prototypes \
+- -Werror=missing-declarations \
+- -Werror=format=2 \
+- -Werror=undef \
+- -Werror=missing-include-dirs \
+- -Werror=strict-aliasing=2 \
+- -Werror=init-self \
+- -Werror=implicit-function-declaration \
+- -Werror=return-type \
+- -Werror=switch \
+- -Werror=overflow \
+- -Werror=parentheses \
+- -Werror=aggregate-return \
+- -Werror=unused-result \
+ -Wno-cast-function-type \
+ -fno-strict-aliasing \
+ "
+
+-AC_DEFUN([CHECK_CCSUPPORT], [
+- my_save_cflags="$CFLAGS"
+- CFLAGS=$1
+- AC_MSG_CHECKING([whether CC supports $1])
+- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
+- [AC_MSG_RESULT([yes])]
+- [$2+=$1],
+- [AC_MSG_RESULT([no])]
+- )
+- CFLAGS="$my_save_cflags"
+-])
+-
+-CHECK_CCSUPPORT([-Werror=format-overflow=2], [flg1])
+-CHECK_CCSUPPORT([-Werror=int-conversion], [flg2])
+-CHECK_CCSUPPORT([-Werror=incompatible-pointer-types], [flg3])
+-CHECK_CCSUPPORT([-Werror=misleading-indentation], [flg4])
+-
+-AC_SUBST([AM_CFLAGS], ["$my_am_cflags $flg1 $flg2 $flg3 $flg4"])
++AC_SUBST([AM_CFLAGS], ["$my_am_cflags"])
+
+ # Make sure that $ACLOCAL_FLAGS are used during a rebuild
+ AC_SUBST([ACLOCAL_AMFLAGS], ["-I $ac_macro_dir \$(ACLOCAL_FLAGS)"])
+--
+2.21.0
+