summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/openmittsu')
-rw-r--r--net-im/openmittsu/Manifest2
-rw-r--r--net-im/openmittsu/files/openmittsu-0.10.0.0-musl.patch25
-rw-r--r--net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch11
-rw-r--r--net-im/openmittsu/metadata.xml2
-rw-r--r--net-im/openmittsu/openmittsu-0.10.0.0.ebuild (renamed from net-im/openmittsu/openmittsu-0.9.15.0.ebuild)15
5 files changed, 35 insertions, 20 deletions
diff --git a/net-im/openmittsu/Manifest b/net-im/openmittsu/Manifest
index 8381d6e3e48f..f396862e2e46 100644
--- a/net-im/openmittsu/Manifest
+++ b/net-im/openmittsu/Manifest
@@ -1 +1 @@
-DIST openmittsu-0.9.15.0.tar.xz 2302908 BLAKE2B 2800004968a1965d0c91197402618ae4ebaeb7a7d977e79654f296d7d2ca1466d26b86d99810e0502e9eced27e5a664dbb4b0113ec344367fb7b85557ebc0381 SHA512 9e00828053506cf233a4cede49c501da903cc36d49379b891e4186cf10cacfbd596b4d2b7ac551e2e6340a878bfa1155f8696e179ed9dd1c2ecbff61430ed7f9
+DIST openmittsu-0.10.0.0.tar.xz 2345724 BLAKE2B 407fe07147b17e6ac6ec2381e77256d09824fce87f1d9d141d2940e566191e911b05fb3d6701d342be9bb667551903f4f8913cbb25f504100e92ab4a38339555 SHA512 d4334c8516efcd63a3e9dfcf9f9655922aa14b2574f39269cf7019a8c951144569138c2a0a75abb16e2746a33002f0c07ef6c86dbdb5405e11c315ec630eb0d0
diff --git a/net-im/openmittsu/files/openmittsu-0.10.0.0-musl.patch b/net-im/openmittsu/files/openmittsu-0.10.0.0-musl.patch
new file mode 100644
index 000000000000..7935ff5530d4
--- /dev/null
+++ b/net-im/openmittsu/files/openmittsu-0.10.0.0-musl.patch
@@ -0,0 +1,25 @@
+Fix compilation with MUSL libc
+https://bugs.gentoo.org/907754
+
+Patch backported from spdlog repository:
+https://github.com/gabime/spdlog/commit/287a00d364990edbb621fe5e392aeb550135fb96
+
+commit 287a00d364990edbb621fe5e392aeb550135fb96
+Author: Khem Raj <raj.khem@gmail.com>
+Date: Tue Jan 3 09:54:50 2023 -0800
+
+ Do not use LFS64 functions on linux/musl (#2589)
+
+--- openmittsu-0.10.0.0/3rdparty/spdlog/include/spdlog/details/os-inl.h
++++ openmittsu-0.10.0.0/3rdparty/spdlog/include/spdlog/details/os-inl.h
+@@ -230,8 +230,8 @@
+ #else
+ int fd = ::fileno(f);
+ #endif
+-// 64 bits(but not in osx or cygwin, where fstat64 is deprecated)
+-#if (defined(__linux__) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
++// 64 bits(but not in osx, linux/musl or cygwin, where fstat64 is deprecated)
++#if ((defined(__linux__) && defined(__GLIBC__)) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
+ struct stat64 st;
+ if (::fstat64(fd, &st) == 0)
+ {
diff --git a/net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch b/net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch
deleted file mode 100644
index c89d24536ae9..000000000000
--- a/net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- openmittsu-0.9.13.32-orig/CMakeLists.txt
-+++ openmittsu-0.9.13.32/CMakeLists.txt
-@@ -570,7 +570,7 @@
- target_link_libraries(openMittsu openMittsuCore Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::Multimedia Qt5::MultimediaWidgets Qt5::Sql)
- target_link_libraries(openMittsuVersionInfo Qt5::Core)
- if (OPENMITTSU_ENABLE_TESTS)
-- target_link_libraries(openMittsuTests openMittsuCore Qt5::Core Qt5::Network Qt5::Multimedia Qt5::MultimediaWidgets Qt5::Sql gmock gtest)
-+ target_link_libraries(openMittsuTests openMittsuCore Qt5::Core Qt5::Network Qt5::Multimedia Qt5::MultimediaWidgets Qt5::Sql gmock gtest pthread)
- endif (OPENMITTSU_ENABLE_TESTS)
-
- # Link against libc++abi if requested.
diff --git a/net-im/openmittsu/metadata.xml b/net-im/openmittsu/metadata.xml
index c665e48637be..10e4ea021b98 100644
--- a/net-im/openmittsu/metadata.xml
+++ b/net-im/openmittsu/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>ulm@gentoo.org</email>
diff --git a/net-im/openmittsu/openmittsu-0.9.15.0.ebuild b/net-im/openmittsu/openmittsu-0.10.0.0.ebuild
index 945996c436ae..dc31c3a2ca06 100644
--- a/net-im/openmittsu/openmittsu-0.9.15.0.ebuild
+++ b/net-im/openmittsu/openmittsu-0.10.0.0.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake desktop
DESCRIPTION="Open source chat client for Threema-style end-to-end encrypted chat networks"
HOMEPAGE="https://www.openmittsu.de/"
-# git-archive-all.sh snapshot of https://github.com/blizzard4591/openMittsu.git
+# snapshot of https://github.com/blizzard4591/openMittsu.git
+# git-archive-all.sh --prefix ${P}/ -- - | xz > ${P}.tar.xz
SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT BSD"
@@ -17,7 +18,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-db/qt5-sqlcipher
- >=dev-libs/libsodium-1.0.11:=
+ >=dev-libs/libsodium-1.0.18:=
>=dev-qt/qtcore-5.7.1:5=
>=dev-qt/qtgui-5.7.1:5=
>=dev-qt/qtmultimedia-5.7.1:5=[widgets]
@@ -28,9 +29,7 @@ RDEPEND="dev-db/qt5-sqlcipher
DEPEND="${RDEPEND}
test? ( >=dev-cpp/gtest-1.8.0 )"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.9.13.32-fix-tests.patch
-)
+PATCHES=( "${FILESDIR}"/${P}-musl.patch )
DOCS=(
README.md
@@ -38,6 +37,8 @@ DOCS=(
Example-contacts-file.txt
)
+CMAKE_BUILD_TYPE="Gentoo"
+
src_configure() {
local mycmakeargs=(
# set version manually, since autodetection works only with git