summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/poezio/poezio-9999.ebuild')
-rw-r--r--net-im/poezio/poezio-9999.ebuild40
1 files changed, 29 insertions, 11 deletions
diff --git a/net-im/poezio/poezio-9999.ebuild b/net-im/poezio/poezio-9999.ebuild
index 0ca4b6cbda4a..cea4492ef2cd 100644
--- a/net-im/poezio/poezio-9999.ebuild
+++ b/net-im/poezio/poezio-9999.ebuild
@@ -4,9 +4,9 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
-inherit distutils-r1 readme.gentoo-r1
+inherit distutils-r1 optfeature xdg
DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
HOMEPAGE="https://poez.io/"
@@ -16,6 +16,9 @@ SLOT="0"
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://lab.louiz.org/${PN}/${PN}.git"
inherit git-r3
+
+ # We build the html documentation using sphinx.
+ BDEPEND="dev-python/sphinx"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64"
@@ -25,16 +28,15 @@ RDEPEND="
dev-python/aiodns[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
- >=dev-python/slixmpp-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/slixmpp-1.7.1[${PYTHON_USEDEP}]
"
+DEPEND="test? ( ${RDEPEND} )"
-distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}/Do-not-install-man-pages-and-files-in-usr-share-poez.patch"
+)
-DOC_CONTENTS="
-Install these optional runtime dependencies for additional features.
-* dev-python/pyinotify for screen autoaway plugin support.
-"
-DISABLE_AUTOFORMATTING=true
+distutils_enable_tests pytest
src_prepare() {
default
@@ -42,11 +44,27 @@ src_prepare() {
rm plugins/mpd_client.py || die
}
+src_compile() {
+ distutils-r1_src_compile
+
+ if [[ -n "${EGIT_REPO_URI}" ]]; then
+ emake -C doc html
+ fi
+}
+
src_install() {
distutils-r1_src_install
- readme.gentoo_create_doc
+
+ doman data/poezio.1 data/poezio_logs.1
+
+ if [[ -n "${EGIT_REPO_URI}" ]]; then
+ docinto html
+ dodoc -r doc/build/html/*
+ fi
}
pkg_postinst() {
- readme.gentoo_print_elog
+ xdg_pkg_postinst
+
+ optfeature "screen autoaway support" dev-python/pyinotify
}