summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/qtox')
-rw-r--r--net-im/qtox/qtox-1.3.0.ebuild6
-rw-r--r--net-im/qtox/qtox-1.4.0.ebuild6
-rw-r--r--net-im/qtox/qtox-9999.ebuild9
3 files changed, 3 insertions, 18 deletions
diff --git a/net-im/qtox/qtox-1.3.0.ebuild b/net-im/qtox/qtox-1.3.0.ebuild
index 3dffe4b24b58..5c25a9ff2cba 100644
--- a/net-im/qtox/qtox-1.3.0.ebuild
+++ b/net-im/qtox/qtox-1.3.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils qmake-utils
@@ -56,10 +56,6 @@ pkg_pretend() {
fi
}
-src_prepare() {
- epatch_user
-}
-
src_configure() {
use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
diff --git a/net-im/qtox/qtox-1.4.0.ebuild b/net-im/qtox/qtox-1.4.0.ebuild
index 054a45136860..ec6d329a938e 100644
--- a/net-im/qtox/qtox-1.4.0.ebuild
+++ b/net-im/qtox/qtox-1.4.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils qmake-utils
@@ -57,10 +57,6 @@ pkg_pretend() {
fi
}
-src_prepare() {
- epatch_user
-}
-
src_configure() {
use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index 19761c5e85dc..0c69c91103c4 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils qmake-utils git-r3
@@ -56,18 +56,11 @@ pkg_pretend() {
fi
}
-src_prepare() {
- epatch_user
-}
-
src_configure() {
use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
- # filter_audio is disabled since it's not available in Gentoo, and
- # support for it in qTox at the present is ~broken anyway
eqmake5 \
PREFIX="${D}/usr" \
- DISABLE_FILTER_AUDIO=YES \
${NO_GTK_SUPPORT} \
${NO_X_SUPPORT}
}