summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/sendxmpp')
-rw-r--r--net-im/sendxmpp/Manifest2
-rw-r--r--net-im/sendxmpp/metadata.xml8
-rw-r--r--net-im/sendxmpp/sendxmpp-1.23.ebuild22
-rw-r--r--net-im/sendxmpp/sendxmpp-1.24.ebuild20
4 files changed, 52 insertions, 0 deletions
diff --git a/net-im/sendxmpp/Manifest b/net-im/sendxmpp/Manifest
new file mode 100644
index 000000000000..a441cd210609
--- /dev/null
+++ b/net-im/sendxmpp/Manifest
@@ -0,0 +1,2 @@
+DIST sendxmpp-1.24.tar.gz 9657 SHA256 dfaf735b4585efd6b3b0f95db31203f9ab0fe607b50e75c6951bc18a6269837d SHA512 349aac46ad4e13836f797f953d1acb33014d66de2bebed4961bcd981b765b5f0014bd2291a7355f0f8e80db522e3e843088fe08c0a21d4dda360dc2834db4842 WHIRLPOOL 81752d7b8843be27db101c0e20ebaccfe14a403f0064214e1b430ddd1117e6b81ab3ccf3e96bcc123e79601bb4658124e11b850799bf6a984cd1127965b5af8f
+DIST sendxmpp_1.23.orig.tar.gz 9196 SHA256 8a8b408ebd1df0157418981035748d9eb2464d353c5ea8ac48b074b8a85b9616 SHA512 65cbda52450a3537982d0c8f94265a1f8c336379ea4e4bc56c772bb613ea03fe25feb85fb4c8e3b26a48ad03d0c5e07188268e07c1da9981cb1dab87b17d9ba8 WHIRLPOOL e522c3950014f1cffc890ab2bdbfe6a4d3c0a9278fb935eec6918ce013011ed6037dcc912b4671c3a8fbca02245f8192ebb915571bf96381a19d6ab923f26a01
diff --git a/net-im/sendxmpp/metadata.xml b/net-im/sendxmpp/metadata.xml
new file mode 100644
index 000000000000..b0475f13df49
--- /dev/null
+++ b/net-im/sendxmpp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <upstream>
+ <remote-id type="github">lhost/sendxmpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/sendxmpp/sendxmpp-1.23.ebuild b/net-im/sendxmpp/sendxmpp-1.23.ebuild
new file mode 100644
index 000000000000..8e1921f7c953
--- /dev/null
+++ b/net-im/sendxmpp/sendxmpp-1.23.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="sendxmpp is a perl-script to send xmpp (jabber), similar to what mail(1) does for mail"
+HOMEPAGE="http://sendxmpp.hostname.sk/"
+SRC_URI="mirror://debian/pool/main/s/sendxmpp/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc sparc x86"
+IUSE=""
+
+RDEPEND="dev-perl/Net-XMPP
+ dev-perl/Authen-SASL
+ virtual/perl-Getopt-Long"
+
+S="${WORKDIR}"/lhost-${PN}-610082b
diff --git a/net-im/sendxmpp/sendxmpp-1.24.ebuild b/net-im/sendxmpp/sendxmpp-1.24.ebuild
new file mode 100644
index 000000000000..114b808f824a
--- /dev/null
+++ b/net-im/sendxmpp/sendxmpp-1.24.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="A perl-script to send xmpp (jabber), similar to what mail(1) does for mail"
+HOMEPAGE="http://sendxmpp.hostname.sk/"
+SRC_URI="https://github.com/lhost/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Net-XMPP
+ dev-perl/Authen-SASL
+ virtual/perl-Getopt-Long"