summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telegram-desktop/telegram-desktop-2.4.5.ebuild')
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.4.5.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-im/telegram-desktop/telegram-desktop-2.4.5.ebuild b/net-im/telegram-desktop/telegram-desktop-2.4.5.ebuild
index 59754b053cac..9c70f67350eb 100644
--- a/net-im/telegram-desktop/telegram-desktop-2.4.5.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-2.4.5.ebuild
@@ -96,8 +96,11 @@ pkg_pretend() {
src_prepare() {
# conditional patching is bad, but we want vanilla telegram with webrtc.
use webrtc || local PATCHES=( "${FILESDIR}/no-webrtc-build.patch" )
- # i asked upstream for explicit toggle, they did not listen. #752417
- sed -i 's/DESKTOP_APP_USE_PACKAGED/DESKTOP_APP_USE_PACKAGED_FAKE/' cmake/external/rlottie/CMakeLists.txt || die
+
+ # no explicit toggle #752417
+ sed -i 's/DESKTOP_APP_USE_PACKAGED/NO_ONE_WILL_EVER_SET_THIS/' \
+ cmake/external/rlottie/CMakeLists.txt || die
+
cmake_src_prepare
}
@@ -116,7 +119,6 @@ src_configure() {
# EXPECTED VARIANT
# gtk is really needed for image copy-paste due to https://bugreports.qt.io/browse/QTBUG-56595
local mycmakeargs=(
- -DCMAKE_DISABLE_FIND_PACKAGE_rlottie=ON # it does not build with system one #752417
-DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON # header only lib, some git version. prevents warnings.
-DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
-DDESKTOP_APP_USE_GLIBC_WRAPS=OFF