summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/ircstats')
-rw-r--r--net-irc/ircstats/Manifest1
-rw-r--r--net-irc/ircstats/ircstats-1.1-r1.ebuild37
-rw-r--r--net-irc/ircstats/metadata.xml5
3 files changed, 43 insertions, 0 deletions
diff --git a/net-irc/ircstats/Manifest b/net-irc/ircstats/Manifest
new file mode 100644
index 000000000000..64402bce438e
--- /dev/null
+++ b/net-irc/ircstats/Manifest
@@ -0,0 +1 @@
+DIST IRCStats-1.1.tgz 47781 SHA256 b75cf327fd543babecd1e25cef966786122ef1c713bd8016b115527cb2e6415a SHA512 009beb7b0aac9138aed6f55131498eefcb004e4478e241dc17ce98b89af607b2599e8ab6879eb1dcd11c6cffad27ded3058bb875eb6516a87c830ed1eda5fe83 WHIRLPOOL d9f219477007933d3f4f63a75d377710cb19829f1bce7bd7701749d83b32a09e5e2e533b65baa1693d7dd1c149119e12e49c9d0fb8d385952b6727bfc362d804
diff --git a/net-irc/ircstats/ircstats-1.1-r1.ebuild b/net-irc/ircstats/ircstats-1.1-r1.ebuild
new file mode 100644
index 000000000000..dc520afc7261
--- /dev/null
+++ b/net-irc/ircstats/ircstats-1.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_P="IRCStats-${PV}"
+
+DESCRIPTION="IRCStats tries to be a log analyzer for Linux similar to mIRCStats"
+HOMEPAGE="http://humdi.net/ircstats/"
+SRC_URI="http://humdi.net/ircstats/${MY_P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin ircstats || die "dobin failed"
+
+ insinto /usr/share/ircstats
+ doins -r html languages colors || die "doins failed"
+
+ dodoc CHANGES README TODO ircstats.cfg || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "The IRCStats files have been installed in /usr/share/ircstats"
+ elog "You can find an example ircstats.cfg in /usr/share/doc/${PF}"
+}
diff --git a/net-irc/ircstats/metadata.xml b/net-irc/ircstats/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/ircstats/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>