summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/limnoria-plugins-chantracker/Manifest1
-rw-r--r--net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20211103.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-chantracker/Manifest b/net-irc/limnoria-plugins-chantracker/Manifest
index 7e1a0450e314..630020da207b 100644
--- a/net-irc/limnoria-plugins-chantracker/Manifest
+++ b/net-irc/limnoria-plugins-chantracker/Manifest
@@ -1,2 +1,3 @@
DIST limnoria-plugins-chantracker-1.5_p20210619.tar.gz 47777 BLAKE2B 14e44e025d4044c38504ec9cea31b08d9a442769b5dc3cf6d71b89526ec98a43a31068a5557b3fc257c6254b0f6aab989d148066b79667b17c75f01e741c10ea SHA512 8ef99fbd41929172ae362a656030fda7f4d522eddfd29a3f9e8f9e9a138903faa672c4b872ce76da39d716f3443c159e7c40111cee015230e781bc387c299718
DIST limnoria-plugins-chantracker-1.6.tar.gz 48050 BLAKE2B aedf93eccbda87eb488b7a0c6e28597198ce37a68a006771b15d6044eea8d7efd9fcf5b178ff4309715534286b74c7ee81e47241ec6406c26d1b17f5bb442d5a SHA512 c7ddd629818edc85d4ebc589d85fa66ef757ac27d0710e4a5512a469892c5c3caad6b98a3ebbce0abc797e0b64bdbd4ad2445e2127c91e266abddec58c3ae859
+DIST limnoria-plugins-chantracker-1.6_p20211103.tar.gz 52922 BLAKE2B a397c4235eb0487d6e84acb8c8dabd78fe1dcd4b64a85b94168fd9be5b3cbaa32049d621348b81b026d68bc1599b7b1db2051a572258e80eb0b8be875d3c9b2a SHA512 bf1c613b1daa979e310bf566e5584004ea824a65464e1b185b58ccc45c62f052d449a25e686eb0faa9657f29ff69b89ec588cf8ea40ad4dff415b9fc02faed04
diff --git a/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20211103.ebuild b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20211103.ebuild
new file mode 100644
index 000000000000..cd60dfb79685
--- /dev/null
+++ b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6_p20211103.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="d8acb0b785924e7d01e65531784aca089368b760"
+
+DESCRIPTION="supybot ban management and channel flood/spam/repeat protections plugin"
+HOMEPAGE="https://github.com/ncoevoet/ChanTracker"
+SRC_URI="https://github.com/ncoevoet/ChanTracker/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~riscv ~x86"
+SLOT=0
+
+RDEPEND="net-irc/limnoria"
+
+DOCS="README.md"
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/ncoevoet/ChanTracker
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before this plugin can be used, your bot will need to be told where to"
+ elog "load it from. To do this, add /usr/share/limnoria-extra-plugins/ncoevoet when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/ncoevoet"
+}