summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ccrtp')
-rw-r--r--net-libs/ccrtp/Manifest2
-rw-r--r--net-libs/ccrtp/ccrtp-2.0.9.ebuild44
-rw-r--r--net-libs/ccrtp/ccrtp-2.1.2.ebuild44
-rw-r--r--net-libs/ccrtp/metadata.xml5
4 files changed, 95 insertions, 0 deletions
diff --git a/net-libs/ccrtp/Manifest b/net-libs/ccrtp/Manifest
new file mode 100644
index 000000000000..d7aa8236dc35
--- /dev/null
+++ b/net-libs/ccrtp/Manifest
@@ -0,0 +1,2 @@
+DIST ccrtp-2.0.9.tar.gz 751786 SHA256 2032176f7d64db05d7bc557a045d0b24ec76f264448a30a7de9f12c5a31530df SHA512 2e63a049ead5bd8a2f3c65d3badb6d6b2a20e185698f62ea9f7e559e8d0aac6151e7a314317d63ea33282c891d75af32571da3471254600abea462097c47dfe3 WHIRLPOOL ad9211c8dcd62ef77a45a59dc906c8af1a4f6b2ca9883cb66afecd97f73cb88c2b019616ea6fad8a496402cd46675ce35084149f8f84777d064ca50683be0d19
+DIST ccrtp-2.1.2.tar.gz 764869 SHA256 f035ca0e1b5d37b78e358f07a25b05c5cdaf2c85c4b31cf29f6be17f288a349e SHA512 a835f57a0eef7cba11c55c93ce2f11ebd8ab4099e7c723043c51e4872f3da87af946fc50fac18b47ea5d72b2a1227b377810e9134c1f3a8982d4ce5944d043e9 WHIRLPOOL cef4015f9537c2b4383bc84bf2ecbc70b3abacb5f21230ea1c613a55a73728450051c1086e549e7b83f24c84c9b3de19fa4acd324bdd55040d9e798c21be7922
diff --git a/net-libs/ccrtp/ccrtp-2.0.9.ebuild b/net-libs/ccrtp/ccrtp-2.0.9.ebuild
new file mode 100644
index 000000000000..15b40ed6ced3
--- /dev/null
+++ b/net-libs/ccrtp/ccrtp-2.0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="GNU ccRTP is an implementation of RTP, the real-time transport protocol from the IETF"
+HOMEPAGE="http://www.gnu.org/software/ccrtp/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 ppc ppc64 x86"
+LICENSE="GPL-2"
+IUSE="doc"
+SLOT="0/2"
+
+RDEPEND=">=dev-cpp/commoncpp2-1.3.0:0=
+ dev-libs/libgcrypt:0=
+ >=dev-libs/ucommon-5.0.0:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use doc && dohtml -r doc/html/*
+}
+
+pkg_postinst() {
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.5.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.5.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.6.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.6.so.0"
+ fi
+}
diff --git a/net-libs/ccrtp/ccrtp-2.1.2.ebuild b/net-libs/ccrtp/ccrtp-2.1.2.ebuild
new file mode 100644
index 000000000000..df7a7ee551bb
--- /dev/null
+++ b/net-libs/ccrtp/ccrtp-2.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="GNU ccRTP is an implementation of RTP, the real-time transport protocol from the IETF"
+HOMEPAGE="http://www.gnu.org/software/ccrtp/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+IUSE="doc"
+SLOT="0/2"
+
+RDEPEND=">=dev-cpp/commoncpp2-1.3.0:0=
+ dev-libs/libgcrypt:0=
+ >=dev-libs/ucommon-5.0.0:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use doc && dohtml -r doc/html/*
+}
+
+pkg_postinst() {
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.5.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.5.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.6.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.6.so.0"
+ fi
+}
diff --git a/net-libs/ccrtp/metadata.xml b/net-libs/ccrtp/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/net-libs/ccrtp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>