summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/enet/enet-1.3.12.ebuild')
-rw-r--r--net-libs/enet/enet-1.3.12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/enet/enet-1.3.12.ebuild b/net-libs/enet/enet-1.3.12.ebuild
new file mode 100644
index 000000000000..fc29b1c024ff
--- /dev/null
+++ b/net-libs/enet/enet-1.3.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base
+
+DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+HOMEPAGE="http://enet.bespin.org/"
+SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.3/2.2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="!${CATEGORY}/${PN}:0"
+
+DOCS=( "ChangeLog" "README" )
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ base_src_install
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+ fi
+}