summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/Manifest5
-rw-r--r--net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch98
-rw-r--r--net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch12
-rw-r--r--net-libs/gsoap/gsoap-2.7.17.ebuild71
-rw-r--r--net-libs/gsoap/gsoap-2.8.12.ebuild75
-rw-r--r--net-libs/gsoap/gsoap-2.8.19.ebuild72
-rw-r--r--net-libs/gsoap/gsoap-2.8.21.ebuild72
-rw-r--r--net-libs/gsoap/gsoap-2.8.22.ebuild72
-rw-r--r--net-libs/gsoap/metadata.xml20
9 files changed, 497 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
new file mode 100644
index 000000000000..09473c22e02a
--- /dev/null
+++ b/net-libs/gsoap/Manifest
@@ -0,0 +1,5 @@
+DIST gsoap_2.7.17.zip 10224444 SHA256 d3af1ce9464b28cacdf1dfbe09b689f8927cbcf3948479996aef52a39afa2c16 SHA512 efb5332e90cbed6013ac2f16b940404cc4de9e84bc85e671cb3588bc6620cd86c8db646a4f3cd77bb3b866dfcc8a793186736ab2241bb8cbaca8d313345d14ac WHIRLPOOL 955e845b5a8b9af1697ca8bcdbb77813f149f7ff162ec51e680c398dab9934c36418572004b7bd24200476b6d45b623f294053b932da2fce94f415becd369af7
+DIST gsoap_2.8.12.zip 19974348 SHA256 51eef118544fa846f4d2dea2eedf91c84c46a1abeafc5eee3dcff783f4015a00 SHA512 7f162936d8d331d94b0aa52042c512167198a8de5a279747f49494b0f17442feb4db2ac5abff54e46350562e774b6bdddc577049f7cb59807cab29b12d797a87 WHIRLPOOL 7557396a154405606b2b2a962ac5f19d4853a792c8f96333576e6229506c9fedd8c5652cc1560566dfb51203362063566d2780becb1e1bb0ca2714fabe0a0330
+DIST gsoap_2.8.19.zip 20628629 SHA256 11571e4274bb678cd979fb6e80caa0f74d41e1b17848fdb5192497553bb2f8fe SHA512 890f46976322cc409081c3fe9731452244c0c1efba9061b2d2d42a9449c0290be7801bf88c90dbce4aedf1118e2f888e83891d8d6c3c40e2add304f68480fc5a WHIRLPOOL 8113c7c80fcd4d39f340a5950a050980a09194a62e50665b9a661efa5eaeb624cc5031412057f50a44dd465e32e7bda188121b92c480bb00ca34ccf5678e2d43
+DIST gsoap_2.8.21.zip 20633048 SHA256 ddda90866288c7c3d50851b276bfa12e0ef2d4af6d280719aad94b1da0ea109a SHA512 c46f6b6c0ef6055df483408038d0bce822dcee42ff581e0a6350000402916a8ce227fd5b34685a09f95189086584a4aad3b2c5b4e86fea70bcfa50b726fd04f9 WHIRLPOOL 3e38a3f8263a4de01727c9562e4da6156946839dbeb8caad5d6ef665b195b8b1b692bcca8cb88b58e80c1c224190fa29cc0e6c2eee7117cd6b8b875619fe41c3
+DIST gsoap_2.8.22.zip 20806602 SHA256 2fdf14e6e4dece9409db53a3c4676a0b25711279bc2a8d8949a46c2d9907308b SHA512 b7a1b44d21e98b90efc68efa5a61ac69a4a312a3ca87ac4379d6ea15d4d81393fc5921212363f99a8cb1f7a28a736f5869c49318e94110de3df36ce20fc11822 WHIRLPOOL 0e7de5379382702c076a74fea875b4dd9bd1aec54c847919c5831afa8a14e1663aa4d97fd1c8088a7b7aaa9b32485561b2b519802f3a4984cfa87f7a8167fd05
diff --git a/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch b/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch
new file mode 100644
index 000000000000..5762d5282211
--- /dev/null
+++ b/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch
@@ -0,0 +1,98 @@
+--- gsoap/samples/factorytest/factorytest.cpp.orig 2009-03-04 01:16:22.300484305 +0100
++++ gsoap/samples/factorytest/factorytest.cpp 2009-03-04 01:15:47.656485143 +0100
+@@ -49,7 +49,7 @@
+ #include "soapH.h"
+ #include "factorytest.nsmap"
+
+-#include <iostream.h>
++#include <iostream>
+
+ // default factory service endpoint:
+ const char *factory = "http://localhost:18085";
+@@ -167,7 +167,7 @@
+ int main(int argc, char **argv)
+ { if (argc > 1)
+ factory = argv[1]; // use factory from command line arg by default
+- cout << "Connecting to factory " << factory << endl;
++ std::cout << "Connecting to factory " << factory << std::endl;
+ Adder adder; // create unique new remote adder object
+ Counter counter1("myCounter"); // new counter object "myCounter" (created if not exists)
+ Counter counter2("myCounter"); // lookup and use counter "myCounter" (this is an alias to counter1!)
+@@ -175,22 +175,22 @@
+ counter1.set(adder.get());
+ adder.add(3.0);
+ counter1.inc();
+- cout << "Adder=" << adder.get() << endl;
+- cout << "Counter=" << counter2.get() << endl; // counter2 is an alias for counter1 so this prints the value of counter1
+- cout << "Sleep for 90 seconds to test factory server purging objects:" << endl;
++ std::cout << "Adder=" << adder.get() << std::endl;
++ std::cout << "Counter=" << counter2.get() << std::endl; // counter2 is an alias for counter1 so this prints the value of counter1
++ std::cout << "Sleep for 90 seconds to test factory server purging objects:" << std::endl;
+ // counter is periodically incremented which keeps it alive
+ sleep(30);
+ counter1.inc();
+- cout << "Counter=" << counter2.get() << endl;
++ std::cout << "Counter=" << counter2.get() << std::endl;
+ sleep(30);
+ counter1.inc();
+- cout << "Counter=" << counter2.get() << endl;
++ std::cout << "Counter=" << counter2.get() << std::endl;
+ sleep(30);
+ counter1.inc();
+- cout << "Counter=" << counter2.get() << endl;
++ std::cout << "Counter=" << counter2.get() << std::endl;
+ // after 90 secs, the adder should be gone
+- cout << "Adder is no longer available:" << endl;
++ std::cout << "Adder is no longer available:" << std::endl;
+ adder.add(3.0);
+- cout << "Adder status = " << adder.status << endl;
++ std::cout << "Adder status = " << adder.status << std::endl;
+ return 0;
+ }
+--- gsoap/samples/lu/luclient.cpp.orig 2009-03-04 01:16:48.632483467 +0100
++++ gsoap/samples/lu/luclient.cpp 2009-03-04 01:17:54.550483188 +0100
+@@ -32,7 +32,7 @@
+ */
+
+ #include "soapH.h"
+-#include <iostream.h>
++#include <iostream>
+
+ const char luserver[] = "http://websrv.cs.fsu.edu/~engelen/luserver.cgi";
+
+@@ -51,14 +51,14 @@
+ a[3].resize(2,3); // 2-element vector indexed from 2 to 3
+ a[3][2] = 1;
+ a[3][3] = 2;
+- cout << "* Demonstration example *" << endl;
+- cout << "Matrix:" << endl;
++ std::cout << "* Demonstration example *" << std::endl;
++ std::cout << "Matrix:" << std::endl;
+ a.print();
+ vector b(soap, 3);
+ b[1] = 1;
+ b[2] = 2;
+ b[3] = 3;
+- cout << "Vector:" << endl;
++ std::cout << "Vector:" << std::endl;
+ b.print();
+ vector x(soap);
+ if (argc < 2)
+@@ -71,7 +71,7 @@
+ soap_print_fault_location(soap, stderr);
+ }
+ else
+- { cout << "Solution vector from service:" << endl;
++ { std::cout << "Solution vector from service:" << std::endl;
+ x.print();
+ }
+ matrix a1(soap);
+@@ -80,7 +80,7 @@
+ soap_print_fault_location(soap, stderr);
+ }
+ else
+- { cout << "Inverse matrix matrix from service:" << endl;
++ { std::cout << "Inverse matrix matrix from service:" << std::endl;
+ a1.print();
+ }
+ soap_destroy(soap);
diff --git a/net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch b/net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch
new file mode 100644
index 000000000000..673deb17c35f
--- /dev/null
+++ b/net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch
@@ -0,0 +1,12 @@
+--- gsoap-2.7/gsoap/Makefile.am 2008-01-27 15:02:36.000000000 -0600
++++ gsoap-2.7mf/gsoap/Makefile.am 2008-01-28 10:24:26.000000000 -0600
+@@ -12,6 +12,9 @@ CLEANFILES=soapcpp2 stdsoap2_cpp.cpp std
+ AM_CXXFLAGS=$(SOAPCPP2_DEBUG) -D$(platform)
+ AM_CFLAGS=$(SOAPCPP2_DEBUG) -D$(platform)
+
++# Install all soapcpp2 and wsdl2h files into /usr/share/gsoap
++nobase_pkgdata_DATA = import/* plugin/* WS/* custom/* extras/*
++
+ ## we cannot build stdsoap2.o from 2 different sources (stdsoap2.cpp and stdsoap2.c), so we need an intermediate target:
+ stdsoap2_ck.c: stdsoap2.cpp
+ $(LN_S) $(srcdir)/stdsoap2.cpp stdsoap2_ck.c
diff --git a/net-libs/gsoap/gsoap-2.7.17.ebuild b/net-libs/gsoap/gsoap-2.7.17.ebuild
new file mode 100644
index 000000000000..ae852ab59b52
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.7.17.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools eutils
+
+MY_P="${PN}-2.7"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc debug examples +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7-fix-pre-iso-headers.patch"
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # causes compilation of app-emulation/virtualbox-ose[vboxwebsrv] to
+ # break (bug #320901):
+ #epatch "${FILESDIR}/${PN}-2.7.15-use_libtool.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ rm -rf "${D}"/usr/lib*/*.la
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}
diff --git a/net-libs/gsoap/gsoap-2.8.12.ebuild b/net-libs/gsoap/gsoap-2.8.12.ebuild
new file mode 100644
index 000000000000..923f02d8c311
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.12.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # Fix configure.in for >=automake-1.13
+ sed 's@AM_CONFIG_HEADER@AC_CONFIG_HEADERS@' -i configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+ use ssl || myconf+="--disable-ssl "
+ use gnutls && myconf+="--enable-gnutls "
+ use ipv6 && myconf+="--enable-ipv6 "
+ econf \
+ ${myconf} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ find "${D}"/usr/ -name "*.la" -exec rm {} \;
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}
diff --git a/net-libs/gsoap/gsoap-2.8.19.ebuild b/net-libs/gsoap/gsoap-2.8.19.ebuild
new file mode 100644
index 000000000000..3962e714be54
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.19.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+ use ssl || myconf+="--disable-ssl "
+ use gnutls && myconf+="--enable-gnutls "
+ use ipv6 && myconf+="--enable-ipv6 "
+ econf \
+ ${myconf} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ find "${D}"/usr/ -name "*.la" -exec rm {} \;
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}
diff --git a/net-libs/gsoap/gsoap-2.8.21.ebuild b/net-libs/gsoap/gsoap-2.8.21.ebuild
new file mode 100644
index 000000000000..3962e714be54
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.21.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+ use ssl || myconf+="--disable-ssl "
+ use gnutls && myconf+="--enable-gnutls "
+ use ipv6 && myconf+="--enable-ipv6 "
+ econf \
+ ${myconf} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ find "${D}"/usr/ -name "*.la" -exec rm {} \;
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}
diff --git a/net-libs/gsoap/gsoap-2.8.22.ebuild b/net-libs/gsoap/gsoap-2.8.22.ebuild
new file mode 100644
index 000000000000..7a558be8fc6c
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.22.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+ use ssl || myconf+="--disable-ssl "
+ use gnutls && myconf+="--enable-gnutls "
+ use ipv6 && myconf+="--enable-ipv6 "
+ econf \
+ ${myconf} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ find "${D}"/usr/ -name "*.la" -exec rm {} \;
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}
diff --git a/net-libs/gsoap/metadata.xml b/net-libs/gsoap/metadata.xml
new file mode 100644
index 000000000000..1611f0c734c3
--- /dev/null
+++ b/net-libs/gsoap/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>swapon@gmail.com</email>
+ <name>Alessio Cassibba</name>
+ </maintainer>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gsoap2</remote-id>
+ </upstream>
+</pkgmetadata>