summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libcrafter/libcrafter-0.3.ebuild')
-rw-r--r--net-libs/libcrafter/libcrafter-0.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libcrafter/libcrafter-0.3.ebuild b/net-libs/libcrafter/libcrafter-0.3.ebuild
new file mode 100644
index 000000000000..ad131de1f696
--- /dev/null
+++ b/net-libs/libcrafter/libcrafter-0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A high level C++ network packet sniffing and crafting library"
+HOMEPAGE="https://github.com/pellegre/libcrafter"
+SRC_URI="https://github.com/pellegre/${PN}/archive/version-${PV}.tar.gz -> ${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+S=${WORKDIR}/${PN}-version-${PV}/${PN}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}