summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libiscsi/libiscsi-9999.ebuild')
-rw-r--r--net-libs/libiscsi/libiscsi-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/libiscsi/libiscsi-9999.ebuild b/net-libs/libiscsi/libiscsi-9999.ebuild
new file mode 100644
index 000000000000..bfb4ad5d3496
--- /dev/null
+++ b/net-libs/libiscsi/libiscsi-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="1"
+inherit autotools-utils
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/sahlberg/libiscsi.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/sahlberg/libiscsi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="iscsi client library and utilities"
+HOMEPAGE="https://github.com/sahlberg/libiscsi"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"