summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/roadrunner/roadrunner-0.9.1.ebuild')
-rw-r--r--net-libs/roadrunner/roadrunner-0.9.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/roadrunner/roadrunner-0.9.1.ebuild b/net-libs/roadrunner/roadrunner-0.9.1.ebuild
new file mode 100644
index 000000000000..d868bfff66b4
--- /dev/null
+++ b/net-libs/roadrunner/roadrunner-0.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# EBuild details
+DESCRIPTION="RoadRunner library provides API for using Blocks Extensible Exchange Protocol"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage" #was http://rr.codefactory.se
+# upstream Died
+SRC_URI="mirror://gentoo/roadrunner-${PV}.tar.gz"
+
+LICENSE="Sleepycat"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+# doc = include documentation
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.2.1
+ >=dev-libs/libxml2-2.5.11"
+
+DEPEND="
+ >=dev-libs/glib-2.2.1
+ >=dev-libs/libxml2-2.5.11
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # Seems that the Makefiles are OK
+ emake DESTDIR="${D}" install || die
+}