summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rpc2/rpc2-2.10.ebuild')
-rw-r--r--net-libs/rpc2/rpc2-2.10.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/rpc2/rpc2-2.10.ebuild b/net-libs/rpc2/rpc2-2.10.ebuild
new file mode 100644
index 000000000000..64f403b452f0
--- /dev/null
+++ b/net-libs/rpc2/rpc2-2.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Remote procedure call package for IP/UDP (used by Coda)"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/rpc2/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/lwp-2.5"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc README.ipv6
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}