summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/qmhandle')
-rw-r--r--net-mail/qmhandle/Manifest2
-rw-r--r--net-mail/qmhandle/files/qmHandle-gentoo-svc.patch17
-rw-r--r--net-mail/qmhandle/files/qmHandle-gentoo.patch17
-rw-r--r--net-mail/qmhandle/metadata.xml17
-rw-r--r--net-mail/qmhandle/qmhandle-1.2.0-r1.ebuild33
-rw-r--r--net-mail/qmhandle/qmhandle-1.3.2.ebuild34
6 files changed, 120 insertions, 0 deletions
diff --git a/net-mail/qmhandle/Manifest b/net-mail/qmhandle/Manifest
new file mode 100644
index 000000000000..7fc4caf989b3
--- /dev/null
+++ b/net-mail/qmhandle/Manifest
@@ -0,0 +1,2 @@
+DIST qmhandle-1.2.0.tar.gz 13134 SHA256 001530bedb8b3f2696a645abd28a5af3c46fa31e0e0208f94287920d784433bd
+DIST qmhandle-1.3.2.tar.gz 15423 SHA256 a626888b6d208bea80e79fc18f38da5a13c5afd0f920abe9909d3aa2ca4dfa8f
diff --git a/net-mail/qmhandle/files/qmHandle-gentoo-svc.patch b/net-mail/qmhandle/files/qmHandle-gentoo-svc.patch
new file mode 100644
index 000000000000..fc516d4e0b7a
--- /dev/null
+++ b/net-mail/qmhandle/files/qmHandle-gentoo-svc.patch
@@ -0,0 +1,17 @@
+--- qmHandle.orig 2005-08-24 19:39:11.000000000 +0200
++++ qmHandle 2005-08-24 19:40:15.000000000 +0200
+@@ -29,8 +29,12 @@
+ #my ($startqmail) = '/usr/local/bin/svc -u /service/qmail-send';
+
+ # While this is if you have a Debian GNU/Linux with its qmail package
+-my ($stopqmail) = '/etc/init.d/qmail stop';
+-my ($startqmail) = '/etc/init.d/qmail start';
++#my ($stopqmail) = '/etc/init.d/qmail stop';
++#my ($startqmail) = '/etc/init.d/qmail start';
++
++# Gentoo Linux:
++my ($stopqmail) = '/usr/bin/svc -d /var/qmail/supervise/qmail-send';
++my ($startqmail) = '/usr/bin/svc -u /var/qmail/supervise/qmail-send';
+
+ # If you don't have scripts, leave $stopqmail blank (the process will
+ # be hunted and killed by qmHandle):
diff --git a/net-mail/qmhandle/files/qmHandle-gentoo.patch b/net-mail/qmhandle/files/qmHandle-gentoo.patch
new file mode 100644
index 000000000000..bfd8d56fe021
--- /dev/null
+++ b/net-mail/qmhandle/files/qmHandle-gentoo.patch
@@ -0,0 +1,17 @@
+--- qmHandle.orig 2003-08-04 22:54:29.000000000 -0700
++++ qmHandle 2003-08-04 22:55:58.000000000 -0700
+@@ -26,8 +26,12 @@
+ #my ($startqmail) = '/usr/local/bin/svc -u /service/qmail-send';
+
+ # While this is if you have a Debian GNU/Linux with its qmail package
+-my ($stopqmail) = '/etc/init.d/qmail stop';
+-my ($startqmail) = '/etc/init.d/qmail start';
++#my ($stopqmail) = '/etc/init.d/qmail stop';
++#my ($startqmail) = '/etc/init.d/qmail start';
++
++# Gentoo makes life easier:
++my ($stopqmail) = '/var/qmail/bin/qmail-control stop';
++my ($startqmail) = '/var/qmail/bin/qmail-control start';
+
+ # If you don't have scripts, leave $stopqmail blank (the process will
+ # be hunted and killed by qmHandle):
diff --git a/net-mail/qmhandle/metadata.xml b/net-mail/qmhandle/metadata.xml
new file mode 100644
index 000000000000..bfd4139d2e0a
--- /dev/null
+++ b/net-mail/qmhandle/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qmail</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription>qmHandle is a tool which can be used to manage the qmail
+ message queue. It's written in Perl (so fully customizable) and much more
+ powerful than qmail-qread and qmail-qstat. Key features are colored output
+ and the ability to view and delete messages in the queue.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">qmhandle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/qmhandle/qmhandle-1.2.0-r1.ebuild b/net-mail/qmhandle/qmhandle-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..67c53495af70
--- /dev/null
+++ b/net-mail/qmhandle/qmhandle-1.2.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Qmail message queue tool"
+HOMEPAGE="http://qmhandle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qmhandle/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="
+ virtual/qmail
+ dev-lang/perl
+ sys-process/psmisc
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/qmHandle-gentoo-svc.patch
+}
+
+src_install() {
+ dodoc README HISTORY
+ dobin qmHandle || die "dobin failed"
+}
diff --git a/net-mail/qmhandle/qmhandle-1.3.2.ebuild b/net-mail/qmhandle/qmhandle-1.3.2.ebuild
new file mode 100644
index 000000000000..ff6e0383888b
--- /dev/null
+++ b/net-mail/qmhandle/qmhandle-1.3.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Qmail message queue tool"
+HOMEPAGE="http://qmhandle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qmhandle/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="virtual/qmail
+ dev-lang/perl
+ sys-process/psmisc
+"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed \
+ -e 's|/usr/local/bin/svc|/usr/bin/svc|g' \
+ -e 's|/service/qmail-deliver|/var/qmail/supervise/qmail-send|g' \
+ -i qmHandle
+}
+
+src_install() {
+ dodoc README HISTORY
+ dobin qmHandle || die "dobin failed"
+}