summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/axel/axel-2.3-r1.ebuild')
-rw-r--r--net-misc/axel/axel-2.3-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/axel/axel-2.3-r1.ebuild b/net-misc/axel/axel-2.3-r1.ebuild
new file mode 100644
index 000000000000..81905b863f99
--- /dev/null
+++ b/net-misc/axel/axel-2.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/2718/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ~ppc64 sparc x86 ~x86-fbsd"
+IUSE="debug nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}"
+
+#S="${WORKDIR}/${PN}-1.1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Set LDFLAGS and fix expr
+ sed -i -e 's/expr/& --/' -e "s/^LFLAGS=$/&${LDFLAGS}/" configure
+}
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--debug=1"
+ use nls && myconf="--i18n=1"
+ econf \
+ --strip=0 \
+ --etcdir=/etc \
+ ${myconf} \
+ || die
+
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc API CHANGES CREDITS README axelrc.example
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND='\''/usr/bin/axel -a -o "\${DISTDIR}/\${FILE}.axel" "\${URI}" && mv "\${DISTDIR}/\${FILE}.axel" "\${DISTDIR}/\${FILE}"'\'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}