summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/electrum-ltc/files')
-rw-r--r--net-misc/electrum-ltc/files/3.1.2-no-user-root.patch17
-rw-r--r--net-misc/electrum-ltc/files/3.2.3-pip-optional-pkgs.patch11
-rw-r--r--net-misc/electrum-ltc/files/3.3.2-desktop.patch20
3 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/electrum-ltc/files/3.1.2-no-user-root.patch b/net-misc/electrum-ltc/files/3.1.2-no-user-root.patch
new file mode 100644
index 000000000000..0d4781717714
--- /dev/null
+++ b/net-misc/electrum-ltc/files/3.1.2-no-user-root.patch
@@ -0,0 +1,17 @@
+diff -Naur Electrum-3.1.2.orig/setup.py Electrum-3.1.2/setup.py
+--- Electrum-3.1.2.orig/setup.py 2018-03-28 04:51:11.000000000 -0400
++++ Electrum-3.1.2/setup.py 2018-03-31 15:05:45.540757981 -0400
+@@ -28,13 +28,6 @@
+ opts, _ = parser.parse_known_args(sys.argv[1:])
+ usr_share = os.path.join(sys.prefix, "share")
+ icons_dirname = 'pixmaps'
+- if not os.access(opts.root_path + usr_share, os.W_OK) and \
+- not os.access(opts.root_path, os.W_OK):
+- icons_dirname = 'icons'
+- if 'XDG_DATA_HOME' in os.environ.keys():
+- usr_share = os.environ['XDG_DATA_HOME']
+- else:
+- usr_share = os.path.expanduser('~/.local/share')
+ data_files += [
+ (os.path.join(usr_share, 'applications/'), ['electrum.desktop']),
+ (os.path.join(usr_share, icons_dirname), ['icons/electrum.png'])
diff --git a/net-misc/electrum-ltc/files/3.2.3-pip-optional-pkgs.patch b/net-misc/electrum-ltc/files/3.2.3-pip-optional-pkgs.patch
new file mode 100644
index 000000000000..6d62f5675764
--- /dev/null
+++ b/net-misc/electrum-ltc/files/3.2.3-pip-optional-pkgs.patch
@@ -0,0 +1,11 @@
+diff -Naur a/setup.py b/setup.py
+--- a/setup.py 2018-09-17 12:56:34.000000000 +0100
++++ b/setup.py 2018-10-14 14:46:16.524385198 +0100
+@@ -72,7 +72,6 @@
+ name="Electrum",
+ version=version.ELECTRUM_VERSION,
+ install_requires=requirements,
+- extras_require=extras_require,
+ packages=[
+ 'electrum',
+ 'electrum.gui',
diff --git a/net-misc/electrum-ltc/files/3.3.2-desktop.patch b/net-misc/electrum-ltc/files/3.3.2-desktop.patch
new file mode 100644
index 000000000000..c75f282182e7
--- /dev/null
+++ b/net-misc/electrum-ltc/files/3.3.2-desktop.patch
@@ -0,0 +1,20 @@
+--- a/electrum-ltc.desktop
++++ b/electrum-ltc.desktop
+@@ -3,7 +3,7 @@
+
+ [Desktop Entry]
+ Comment=Lightweight Litecoin Client
+-Exec=sh -c "PATH=\"\\$HOME/.local/bin:\\$PATH\"; electrum-ltc %u"
++Exec=electrum-ltc %u
+ GenericName[en_US]=Litecoin Wallet
+ GenericName=Litecoin Wallet
+ Icon=electrum-ltc
+@@ -15,8 +15,3 @@
+ Terminal=false
+ Type=Application
+ MimeType=x-scheme-handler/litecoin;
+-Actions=Testnet;
+-
+-[Desktop Action Testnet]
+-Exec=sh -c "PATH=\"\\$HOME/.local/bin:\\$PATH\"; electrum-ltc --testnet %u"
+-Name=Testnet mode