summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/htun')
-rw-r--r--net-misc/htun/Manifest1
-rw-r--r--net-misc/htun/files/README.gentoo3
-rw-r--r--net-misc/htun/files/htun-0.9.6-glibc.patch14
-rw-r--r--net-misc/htun/files/htun-0.9.6-makefile.patch22
-rw-r--r--net-misc/htun/htun-0.9.6.ebuild39
-rw-r--r--net-misc/htun/metadata.xml8
6 files changed, 87 insertions, 0 deletions
diff --git a/net-misc/htun/Manifest b/net-misc/htun/Manifest
new file mode 100644
index 000000000000..355750f42f01
--- /dev/null
+++ b/net-misc/htun/Manifest
@@ -0,0 +1 @@
+DIST htun-0.9.6.tar.gz 63745 SHA256 acf330a37f1ac676dcb82160f43f12e0b266263f8bf918d9990f1e17e57ed83f SHA512 d709e9b6a809df5711b3c3c61c207a0ce72a054904fbe0a39bb9c60f174b19eb5fe183e3218100f45941035f72c5212fcbd716858631d1f117e6f88608f8ea0d WHIRLPOOL 3ce553377c2107814455f9d421d5bf2cbfdb40b68e371fc3f078b2a32bfe486861d4d8a683b427238952873651606184186f9e425f22f57d34a0295c0f105a36
diff --git a/net-misc/htun/files/README.gentoo b/net-misc/htun/files/README.gentoo
new file mode 100644
index 000000000000..1710c726723a
--- /dev/null
+++ b/net-misc/htun/files/README.gentoo
@@ -0,0 +1,3 @@
+NOTE: HTun requires the Universal TUN/TAP module
+available in the Linux kernel. Make sure you have
+compiled the tun.o driver as a module!
diff --git a/net-misc/htun/files/htun-0.9.6-glibc.patch b/net-misc/htun/files/htun-0.9.6-glibc.patch
new file mode 100644
index 000000000000..66f9b5ba00a5
--- /dev/null
+++ b/net-misc/htun/files/htun-0.9.6-glibc.patch
@@ -0,0 +1,14 @@
+get things building with glibc-2.8
+
+http://bugs.gentoo.org/248100
+
+--- include/common.h
++++ include/common.h
+@@ -23,6 +23,7 @@
+ #ifndef __COMMON_H
+ #define __COMMON_H
+
++#include <limits.h>
+ #include <netinet/in.h>
+ #include <time.h>
+ #include "queue.h"
diff --git a/net-misc/htun/files/htun-0.9.6-makefile.patch b/net-misc/htun/files/htun-0.9.6-makefile.patch
new file mode 100644
index 000000000000..0a94966802d8
--- /dev/null
+++ b/net-misc/htun/files/htun-0.9.6-makefile.patch
@@ -0,0 +1,22 @@
+--- src/Makefile 2005-10-27 12:58:53.000000000 +0200
++++ src/Makefile 2013-03-08 22:20:52.360922189 +0100
+@@ -20,16 +20,14 @@
+
+ # $Id$
+
+-
+-CFLAGS = -I../include -I. -O -W -Wall -g -D_REENTRANT #-pg -a
+-LDFLAGS = -lfl -lpthread # -flex for linux, solaris ?
+-LEX_CFLAGS = -I../include -I. -g -D_REENTRANT #-pg -a
++CFLAGS := $(CFLAGS) -I../include -I. -O -W -Wall -D_REENTRANT
++LDFLAGS := $(LDFLAGS) -lfl -lpthread
++LEX_CFLAGS = -I../include -I. -D_REENTRANT
+
+ # in Linux, LFLAGS is empty. In Solaris, LFLAGS = -lnsl -lsocket
+ #LFLAGS = -lnsl -lsocket
+
+ VPATH = .:../include
+-CC := gcc
+ LEX = flex
+ YACC = yacc
+ INCLUDE := $(wildcard ../include/*.h)
diff --git a/net-misc/htun/htun-0.9.6.ebuild b/net-misc/htun/htun-0.9.6.ebuild
new file mode 100644
index 000000000000..e5ffb4446aa3
--- /dev/null
+++ b/net-misc/htun/htun-0.9.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="Project to tunnel IP traffic over HTTP"
+HOMEPAGE="http://linux.softpedia.com/get/System/Networking/HTun-14751.shtml"
+SRC_URI="http://www.sourcefiles.org/Networking/Tools/Proxy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# should not be replaced by virtual/yacc
+# at least failed with dev-util/bison
+DEPEND="dev-util/yacc"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc.patch #248100
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ epatch_user
+}
+
+src_compile() {
+ emake -C src CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin src/htund
+ insinto /etc
+ doins doc/htund.conf
+ dodoc doc/* README
+ readme.gentoo_create_doc
+}
diff --git a/net-misc/htun/metadata.xml b/net-misc/htun/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/net-misc/htun/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>