summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/keychain/keychain-2.7.1-r2.ebuild')
-rw-r--r--net-misc/keychain/keychain-2.7.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/keychain/keychain-2.7.1-r2.ebuild b/net-misc/keychain/keychain-2.7.1-r2.ebuild
new file mode 100644
index 000000000000..cee0b6475168
--- /dev/null
+++ b/net-misc/keychain/keychain-2.7.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="manage ssh and GPG keys in a convenient and secure manner. Frontend for ssh-agent/ssh-add"
+HOMEPAGE="http://www.funtoo.org/wiki/Keychain"
+SRC_URI="http://www.funtoo.org/archive/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash
+ virtual/ssh"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-openssh-6.8.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ChangeLog README.rst
+}