summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/nemesis/nemesis-1.4.ebuild')
-rw-r--r--net-misc/nemesis/nemesis-1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/nemesis/nemesis-1.4.ebuild b/net-misc/nemesis/nemesis-1.4.ebuild
new file mode 100644
index 000000000000..e24abb77e5f1
--- /dev/null
+++ b/net-misc/nemesis/nemesis-1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A commandline-based, portable human IP stack for UNIX/Linux"
+HOMEPAGE="http://nemesis.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nemesis/${P/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 sparc x86"
+IUSE=""
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}
+ =net-libs/libnet-1.0*"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-libnet-1.0.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc CREDITS ChangeLog INSTALL README
+}